Window下采用ant 脚本构建Android自动化编译

[来源] 达内    [编辑] 达内   [时间]2012-10-16

以上都是 http://www.cnblogs.com/tankaixiong/archive/2010/11/24/1887156.html 获得。 我写该blog,目的是解决我们这样的问题: android项目依赖UserLibrary的问题

  1. http://ant.apache.org/ 下载最新的ant脚本s

  2. android update project --name Tank -t 11 -p F:\tank

  3. 出现“警告:编码 ascii 的不可映射字符”错误编译乱码解决办法: 找到\tools\ant\ant_rules_r3.xml。打开找到节点: 把ascii改为gbk即可。

  以上都是 http://www.cnblogs.com/tankaixiong/archive/2010/11/24/1887156.html 获得。 我写该blog,目的是解决我们这样的问题: android项目依赖UserLibrary的问题。

  bootclasspathref="android.target.classpath" verbose="${verbose}" classpath="${extensible.classpath}">

  将bootclasspathref定义如下:

  然后将以上找到的节点改成如下 :

  bootclasspathref="myandroid.target.classpath" verbose="${verbose}" classpath="${extensible.classpath}">

  讲过验证,没有问题。

资源下载